Sign in to follow this  
Followers 0
IceBlue8

Strange warning light behaviour

4 posts in this topic

Has anyone else experienced this?

Some time ago the engine management system warning light came on and was diagnosed as a catalytic converter fault. This was confirmed by a second garage, but they assured me nothing was wrong with the cat or the sensor. Within a thousand miles or so the warning light went off. But then a thousand miles or so later, it came back on again. Then, you guesssed it, a thousand miles or so later it went off again!

It's a 2002 2.8, if that's relevant. Any ideas?

Share this post


Link to post
Share on other sites

Its probably a lazy oxygen / lambda sensor either pre or post cat. The other possibility is that you have picked up a cr@p load of petrol.

Either of these could fool the engine management into thinking the catalytic converter is not doing its job properly. The cure for both is often the same - fill up with some high octane fuel and have some fun giving the car a good thrashing.

HTH

Alan

Share this post


Link to post
Share on other sites

Like the idea of high octane fuel and a good thrashing - off to Aberdeen next week, so as long as I watch for the cameras with the RoadAngel, that should do! I'll tell the wife that this was technical advice! Thanks

Share this post


Link to post
Share on other sites

I'm pretty sure that the 2.8 only has pre cat O2 sensors BTW

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0