Sign in to follow this  
Followers 0
BatNissanMan

Vehicle stalls on LH turn or when reverse is sellected

3 posts in this topic

Can anyone help me with this problem?

Vehicle stalls when at operating temperature and reverse is selected or when turning left.

Vehicle has covered 250,000Km is a 1994 3L. V6 Nissan Maxima sedan unleaded petrol / LPG Venturi system, normally runs sweetly. The car is poorly maintained, largely by myself as I tend to drive it until it stops, then make minimal tweaks and adjustments to get it running OK, repair parts or use second hand were possible. The car is normally run on LPG but the fault also occurs on petrol, currently the petrol injectors are crook and the front engine mount is shot.

I feel intimidated by the complex engine management system and am at a loss as to target troubleshooting the current problem.

A mechanic has tried a scanner on the electrics, replaced a faulty ignition lead, adjusted the mixture without identification of the problem.

Share this post


Link to post
Share on other sites

:grin: hi and welcome to TSN - I've just moved this to the Japanese section from the French section +++

fingers crossed someone with a lot more practical knowledge than me will be along to help soon +++

Share this post


Link to post
Share on other sites
Can anyone help me with this problem?

Vehicle has covered 250,000Km is a 1994 3L. V6 Nissan Maxima sedan unleaded petrol / LPG Venturi system, normally runs sweetly. The car is poorly maintained, largely by myself as I tend to drive it until it stops, then make minimal tweaks and adjustments to get it running OK, repair parts or use second hand were possible. The car is normally run on LPG but the fault also occurs on petrol, currently the petrol injectors are crook and the front engine mount is shot.

You've pretty much answered your own question, high milegage and an LPG conversion in an older car need to be cared for like a new born baby otherwise a host of problems can occur.

From a quick google i've found this: '95 Maxima stalls after warming up - help (long) - NissanForums.com :: Nissan Forum

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0