Jump to content


Photo
- - - - -

Audi A4 B7 bi-xenon flickering problem !!!


  • Please log in to reply
24 replies to this topic

#1 bullomar

bullomar

    Shank's Pony

  • Members
  • Pip
  • 4 posts

Posted 05 June 2009 - 01:40 PM

Hi to all,

as I have annoying problems with my bi-xenon flickering head lights, I would like to ask you guys to help me solve it if anyone had the same problem?

Problem started some 2-3 months ago, at the beginning my bi-xenon's started just flickering, but now, after they flicker, they turn off.
After I turn off and on both headlights on the switch, they work again fine for some period but than again, they start flickering and shutting down again.
My both bi-xenon bulbs look fine, and the light is very bright at night so I dont think my bulbs will die.

Also, I have noticed that they go off if there is bumping road.
I want to mention also that I have also adaptive lights so maybe they could make some troubles to bulbs too.

Please try to help me solve my problem, I am going crazy at night when sometimes I need to turn them off and back on for several times in 5 minutes....


Thank you

#2 PetrolDave

PetrolDave

    Audi RS4

  • Members
  • 3,398 posts

Posted 05 June 2009 - 03:57 PM

Most likely you have a problem with the igniter modules.

#3 wyliss

wyliss

    Audi S3

  • Members
  • 1,417 posts

Posted 05 June 2009 - 03:58 PM

Hi to all,

as I have annoying problems with my bi-xenon flickering head lights, I would like to ask you guys to help me solve it if anyone had the same problem?

Problem started some 2-3 months ago, at the beginning my bi-xenon's started just flickering, but now, after they flicker, they turn off.
After I turn off and on both headlights on the switch, they work again fine for some period but than again, they start flickering and shutting down again.
My both bi-xenon bulbs look fine, and the light is very bright at night so I dont think my bulbs will die.

Also, I have noticed that they go off if there is bumping road.
I want to mention also that I have also adaptive lights so maybe they could make some troubles to bulbs too.

Please try to help me solve my problem, I am going crazy at night when sometimes I need to turn them off and back on for several times in 5 minutes....


Thank you

Hi and welcome to TSN.
I had the same problem last year and the dealer replaced the xenon control unit which sits behind each lamp. +++
A4 B7 2.0T FSI S-LINE Akoya Silver, Xenon plus pack, RS 6's, MFSW, Phatnoise, Auto dimming mirror, Light/Rain sensor, Cruise control, Bose, Isofix, Split folding seats, Rear side blinds, Rear window blind, Centre armrest, Auto boot Lid, Cargo parcel net/hooks,Loadliner & Votex Rear Diffuser. Recently added black optics front grill !

#4 bullomar

bullomar

    Shank's Pony

  • Members
  • Pip
  • 4 posts

Posted 05 June 2009 - 11:33 PM

Thank you both, PetrolDave and dibbs for your answers.

Dave, please tell me, are you both mentioning the same thing for my problem?

As I know, those control units which dibbs mentioned are very expensive, am I wright?

thanks

#5 PetrolDave

PetrolDave

    Audi RS4

  • Members
  • 3,398 posts

Posted 10 June 2009 - 04:24 PM

Dave, please tell me, are you both mentioning the same thing for my problem?

Yep, the same thing.

#6 Phantom

Phantom

    Subaru Impreza WRX

  • Members
  • 2,964 posts

Posted 12 June 2009 - 10:47 PM

Same problem with me also, the driver's side light kept flickering and then it got to a stage where it went off four about 4 secs and then came back on again.

I had the Xenon's ECU's replaced two weeks ago during its service. £300 each module , doh, just as well there was still 2 weeks warranty left on the car !

#7 PeterR

PeterR

    Shank's Pony

  • Members
  • Pip
  • 2 posts

Posted 15 July 2009 - 07:53 PM

Hey -

I have the pretty much same problem - Xenon flickering, especially when the curve adaption is heavily working (eg. parking garage). Switching the light off and on again solves the issue.

My questions to all of you:
a) is it just the control units that need to be changed or do the bulbs need to be changed as well?
b) how about Audi warranty in each of your cases? Does Audi replace at no cost or would we have to pay for the units/bulbs/installation?

My warranty comes to an end and the German dealer would charge me 1000EUR for bulbs, installation and remainder of the control units (30%) while Audi would take 70% for the units only.

Comments welcome.

#8 WallyBazoom

WallyBazoom

    Shank's Pony

  • Members
  • Pip
  • 1 posts

Posted 02 November 2009 - 03:34 PM

Hi Guys,

Got the same Flickering and turning off problem. (drivers side only).

Just had the car serviced, and pointed out the problem. (car has still got 3 years warranty)

However, they won't replace the Xenon control unit until the bulbs are changed first, and of course bulbs are not warranty items so they want me to pay over £500 :eek: for a pair of bulbs first.

Is there a way I can prove one way or another that it's the control unit at fault? perhaps swapping the bulbs round and if it still happens on the drivers side, then it must be the control unit.

Cheers,

#9 Grum71

Grum71

    Shank's Pony

  • Members
  • Pip
  • 2 posts

Posted 20 November 2009 - 03:06 PM

Having the same issues myself. My bulb (O/S only) went a girlie shade of pink before 'flickering.' This continued for 3-4 weeks before giving up the ghost.
Audi wanted £162.50 for a replacement bulb (each!) but HIDS-DIRECT came up trumps at £50 a pair.

Replaced both bulbs. 3 days later, bulb failure warning.

Next step - control unit (Ballast) On the B6 S4 this is a 5GL unit.

Again, Stealer wanted £255 so HIDS4U came up trumps with £135 + £5 to the nice postman. I found a code via Google (STRATHY) which lowered the price to £106.

Headlight out, ballast fitted along with the bulb - perfect.

3 days later - bulb failure.

I changed all the 'stuff' (ballasts/bulbs) from the nearside and checked and vice versa. This pin pinted a faulty ballast (the replacement) so I have just taken delivery of it's brother but haven't fitted as yet.

Need to check car wiring before I do.

Any help/advice from you guys is appreciated.

BTW - the headlight that fails does have some condensation in it. A common problem but unsure if this has any relevance.

Grahame

#10 PeterR

PeterR

    Shank's Pony

  • Members
  • Pip
  • 2 posts

Posted 24 March 2010 - 06:41 PM

All -

I finally had both the control units as well as the Xenon bulbs changed, though it cost a lot of Euros. But since then this phenomenon has never again appeared. Very annoying that Audi would not even take over the full costs of the control units. I finally paid around 700 EUR.

Peter.

#11 maersk

maersk

    BMW 130d

  • Members
  • 1,110 posts

Posted 24 March 2010 - 09:01 PM

Doesn't Halogen look good after three years......................................;)
The secret of life, is enjoying the passage of time ............

#12 Sarge786

Sarge786

    Fiat 500

  • Members
  • PipPipPip
  • 43 posts

Posted 01 April 2010 - 02:18 PM

Hi all, I have same issue on my A4 DTM. I understand that the headlights need to be removed to fit new bulbs and Ballasts? this entails removal of the front bumper as well I hear?!

What a farce just to get to and check bulbs :rolleyes:


Sarge

#13 DTM 893

DTM 893

    Shank's Pony

  • Members
  • Pip
  • 1 posts

Posted 16 August 2010 - 09:39 AM

I have owned my DTM from new and love it !!!

However, I have also experienced the same problem as many others with my xenon headlights and need some help.

Clearly, this is a known fault and I would like to know how many of the 250 DTM owners are experiencing the same problem.

Please contact me.

#14 Sarge786

Sarge786

    Fiat 500

  • Members
  • PipPipPip
  • 43 posts

Posted 19 August 2010 - 11:24 PM

I have owned my DTM from new and love it !!!

However, I have also experienced the same problem as many others with my xenon headlights and need some help.

Clearly, this is a known fault and I would like to know how many of the 250 DTM owners are experiencing the same problem.

Please contact me.


How are we to contact you Pal?

Cheers

#15 PetrolDave

PetrolDave

    Audi RS4

  • Members
  • 3,398 posts

Posted 22 August 2010 - 01:54 PM

How are we to contact you Pal?

With a PM?

#16 Sarge786

Sarge786

    Fiat 500

  • Members
  • PipPipPip
  • 43 posts

Posted 22 August 2010 - 10:12 PM

With a PM?


I can't see how to PM him. There is only seems to be a 'visitor message' option as far as I can see.

Perhaps I have some sort of wrong settings set?


Sarge

#17 command

command

    Shank's Pony

  • Members
  • Pip
  • 1 posts

Posted 14 September 2010 - 03:16 PM

This problem is headlamp xenon ballast .

Because A4 B7 xenon system have two types part(ballast and bulb),if bulb is OK, then problem is ballast.

BTW B7 oem ballast like this ,Attached File  2006-2009-Audi-A4-S4-A3-RS4-OEM-Xenon-Ballast.jpg   35.43KB   49 downloads

hope can help some body.

#18 ma54mad

ma54mad

    Shank's Pony

  • Members
  • Pip
  • 2 posts

Posted 30 September 2010 - 09:21 PM

I have a DTM too and I HAVE THE SAME PROBLEM OMGGGG!!!
It is soooooo annoying, especially with such a nice car, the lights flickering on and off isnae doin any good for it! :S anyone managed to get a solution with a reasonable price tag?

#19 tony007

tony007

    Shank's Pony

  • Members
  • Pip
  • 4 posts

Posted 06 July 2011 - 09:50 AM

If light flicker, the problem must be on the ballast.

Before my friend also met this headache problem, and he can not drive his car a period. Finally changed the ballast and problem solved.

But he didn't go to the dealer, he bought the ballast through a online website:

Original OEM Xenon Ballast Ignitor Projector Bulb Wire Harness Bulb Holder Retainers professional supplied by OEM Xenon Part

Cost is much lower than from the car dealer.

Attached Files



#20 solaris

solaris

    Shank's Pony

  • Members
  • PipPip
  • 10 posts

Posted 06 July 2011 - 10:16 AM

I have a DTM and the same issue on the drivers side. Does anybody know the part number of the Balast? a couple of people in the states have addressed this problem by opening up the balast and changing the resistors /transformers.

Xenon Flickering issue: Problem Fixed




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users