Sign in to follow this  
Followers 0
neil6368

cut out probs with my sccoby

12 posts in this topic

hi all im neil i have an impreza turbo 2.0 and when i give it some welly round corners it cuts out can anybody tell me why,

its pissing me off lol

Edited by neil6368

Share this post


Link to post
Share on other sites

Welcome to TSN, there's a few Subaru drivers on here, but we are the minority!

With regards to your problem, which Impreza do you have? it could be the fuel pick up has broken in the tank, it sounds like a fueling problem, does it cut out completely? so you have to restart, or does it misfire a bit then carry on once your past the corner?

Share this post


Link to post
Share on other sites
Welcome to TSN, there's a few Subaru drivers on here, but we are the minority!

With regards to your problem, which Impreza do you have? it could be the fuel pick up has broken in the tank, it sounds like a fueling problem, does it cut out completely? so you have to restart, or does it misfire a bit then carry on once your past the corner?

yep; we need more info... I had a WRX and chopped it in for a WR1 that got crushed by a tree while I was NOT driving it.....

Edited by scooby_simon

Share this post


Link to post
Share on other sites
Welcome to TSN, there's a few Subaru drivers on here, but we are the minority!

With regards to your problem, which Impreza do you have? it could be the fuel pick up has broken in the tank, it sounds like a fueling problem, does it cut out completely? so you have to restart, or does it misfire a bit then carry on once your past the corner?

it misfires my friend then carrys on wat apain in the arse

Share this post


Link to post
Share on other sites
it misfires my friend then carrys on wat apain in the arse

its a 98 2.0 turbo awd thanks

Share this post


Link to post
Share on other sites

Does it make any difference how much fuel you have in the tank? I.e. Does it stop doing it on a full tank?

Have you checked under the bonnet for any loose electrics, and made sure the coil packs are bolted in?

Share this post


Link to post
Share on other sites

i havent done any thing yet ill try it on a full tank and get back to you all and i will check the coil packs oh by the way were are the coil packs im a bit thick when it comes to stuff like that

Share this post


Link to post
Share on other sites

There should be two on either side of the engine, 4 total, where you would expect to find the spark plugs, as they sit on top of the plugs.

Share this post


Link to post
Share on other sites

If you're talking serious welly round right handers with less than maybe a third of a tank of fuel, I have a feeling it's a simple case of fuel pump versus gravity. Only ever happened to me on track, specifically round the Melbourne hairpin at Donington!

(And yes it was the misfire that made me spin... :uhoh: )

Only other misfire issue I had was when it was overfilled with oil once.

Share this post


Link to post
Share on other sites

well im hoping thats the case mate is there anyting i can do about this as its a bit of a pain

Share this post


Link to post
Share on other sites

If it's happening alot then I think there's probably something else wrong. The fuel starvation problem I had was only at really extreme lateral g.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0