Sign in to follow this  
Followers 0
Phil25

Help Reoccurring problems with my mk4 GTI

2 posts in this topic

Hi all, firstly i am new to Tyresmoke so please forgive me if i waffle on a bit!

I have had my golf gti in and out of my local garage for the past 12 months with what appears to be a reoccurring problem. My EPC and Emmisions lights keep coming on and causing poor running of the car, it is lumpy and hardly driveable at all when the exhaust emmisions light is on and looses power when the EPC light is on, the traction control light also lights up but don't really notice an effect. The strange thing is that whenever i take this car to my local garage they do a diagnostics on the car and then clear the fault codes and the car starts running perfectly but then will always reoccur. Now my local garage has told me to take my car to my VW dealer but i fear this is going to be quite expensive as now the garage have provided me with a list of the fault codes and there are about 9 or 10, on their advice i have just had a new battery fitted however the problem reoccurred this morning! :( Any help would be appreciated as i just have no idea what it could be!

Share this post


Link to post
Share on other sites

What year and what engine? My first instinct though would be a faulty MAF.

Oh and welcome to the forum.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0