Sign in to follow this  
Followers 0
Jilly

Exhaust emission warning lamp on 2004 VW Golf TDI

5 posts in this topic

I have searched on this forum for this topic but can't see anyone with quite the same behaviour as my Exhaust Emission warning light.

I have had many Golfs but the 2004 I have now has the exhaust emission warning lamp staying on (but not flashing) once the key is turned the first turn for as long as you leave it first turned. When I first got this car I'm sure that only the battery and handbrake lights used to stay on until the key was turned second turn to start the engine.

If this light is staying on all the time you have the key just at first turn i.e. until the engine is actually started is there a problem? The car seems to be running perfectly OK otherwise?

Share this post


Link to post
Share on other sites

You will have to get it looked at by somebody Like a VW specialist or a good VW retailer.......dont leave it too long.+++

Share this post


Link to post
Share on other sites
You will have to get it looked at by somebody Like a VW specialist or a good VW retailer.......dont leave it too long.+++

+1

There are many things that cause this light to come on, it's impossible to find the fault without a diagnostics scan.

Share this post


Link to post
Share on other sites
I have searched on this forum for this topic but can't see anyone with quite the same behaviour as my Exhaust Emission warning light.

I have had many Golfs but the 2004 I have now has the exhaust emission warning lamp staying on (but not flashing) once the key is turned the first turn for as long as you leave it first turned. When I first got this car I'm sure that only the battery and handbrake lights used to stay on until the key was turned second turn to start the engine.

If this light is staying on all the time you have the key just at first turn i.e. until the engine is actually started is there a problem? The car seems to be running perfectly OK otherwise?

So what was the problem and solution mate?! I have the exactly the same problem?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0