Sign in to follow this  
Followers 0
dombrett1

e30 no spark no fuel please help ???

10 posts in this topic

hello all just thought i would write this up on here too as not getting much help elsewere, so the problem :

ok I have a 318i converted to 325i with engine loom,gearbox,engine. Now im not getting a spark or no fuel coming through,

before i ripped the 2.5 out it ran and when the 318 ran aswell but had headgasket gone.

so i have checked all my earths my lives and i have tried bridging my fuel relays. I have searched every where that if my crank sensors

are down i wont get either (fuel/spark)

but i did find a earth connected to a blue/yellow wire, so am wundering if my ecu has tripped or i have a faulty crank sensor ? i have tried

the fuel pump direct from a battery and is totally fine and working

any help is much appreciated

thanks dom

Share this post


Link to post
Share on other sites

Sorry Geezer not sure I can help.

Maybe a few others will be along. But can you get the ECU checked at all?

Presume the engine cranks as you turn the key?

Share this post


Link to post
Share on other sites

hey engine cranks fine and i dont know how to check the ecu i am just on the case for buying one for spare as there getting hard to find anyway. but i gues the ecu is fine

cheers dom

Share this post


Link to post
Share on other sites

I'll second the E30zone suggestion - an incredibly useful source of info for these cars which I used/read a lot when I had a E30 (325i touring). Brian Moooooore on there (?? the number of 'o's !!) is a legend +++

Peter

Share this post


Link to post
Share on other sites

I'd check the main relay to the coil and injectors - it should be a direct feed from the battery that gets switched to live when the ECU is switched on.

Share this post


Link to post
Share on other sites

i have checked nearly all posabilities but im going to buy a new ecu and crank sensors just for the fact of haveing them spare, also brian mooore is on it now but i dont seem to get much and yes he does seem to be a legend lol

checked all relays ! checked all earths checked all plugs,leads,coil,rotor and cap,basicly what brian has told me lol and what i have read else where

cheers though but anything else i might have missed ?

thanks dom

Share this post


Link to post
Share on other sites

Well the first place I would start would be to use a multimeter and see whether power is actually getting through to each coil. Same for the fuel. Is the pump priming or not? Is fuel flowing and, if so, at what pressure etc.

One step at a time and tick stuff off once you've found it's OK. If it's not, then fix that and move on to the next thing +++

Share this post


Link to post
Share on other sites

ok things i have checked

coil 12v+ Checked

earth Checked

ecu 12v+ checked

relays Checked

plugs Checked

fuel pump Checked

Ht leads Checked

rotor and cap checked

things i need to check

Ecu

crank sensors

pin on flywheel

cant think of anything else at the moment

cheers dom

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0