Sign in to follow this  
Followers 0
2feezy

Mmi is powerless on my 2005 a8l the display is blank all related systems are down

4 posts in this topic

I started having problems at first with static in the radio if it rained or if I went to a car wash but on and off but now it have completely given out the display is stuck in the upright position and it seems no power is getting to it I have removed the center console took apart the MMI system took out the circuit board cleaned it and the buttons and put it all back together but no luck still. coud it be that I now need a new board? thanks for any help

Share this post


Link to post
Share on other sites

More likely that water has fried something else.

A scan with VAG-COM should identify the culprit. Then A8Parts can help.

Share this post


Link to post
Share on other sites

Would have to be a pretty powerful car wash or rain storm to affect the MMI panel. As suggested it is more likely to be a fault elsewhere, the main locations in the A8 for MMI are the left of the boot, under the passenger floor on a RHD car with phone and in and behind the glovebox for CD changer and MMI controller.

I would suggest the AMP in the boot.

Share this post


Link to post
Share on other sites

Or maybe the radio module?

My MMI was being affected by water ingress on my PF D3, never got an explanation from the garage as to the source.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0