Sign in to follow this  
Followers 0
TBaxie

VW Sharan 05 plate 2.0TDi Electrical problems

2 posts in this topic

Hi there,

As I did not see a specific Sharan section, I thought it would be best to post here, apologize if I put it in the wrong place.

As the title says, I have a VW Sharan 05 plate with a 2.0 TDi Engine.

The car has been suffering weird minor issues, which is started to grow larger and more constant and unsure what could be causing it.

Inital faults with other problems going down wards

Electric Window switches wouldnt work correctly (Drivers side) this got replaced and problems went away.

Now, on and off, no way to judge when it will happen, the drivers door will come down but wont go back up, after turn off's and waiting, it eventually works again.

Similar with the passanger side, sometimes it will go down but not up, this is with either driver/passanger trying to close it.

Then lately, when I try and open a window, if it doesnt want it, the harzards now flash if I touch the window switch :confused:

I also have a problem with my Central locking, where some doors wont lock, it can be random, it can be drivers door, door behind drivers and all werid combinations. I note my flip key thob no longer seems to open/close doors at all even with battery replaced.

Spare key which isnt a flip key works but as mentioned, sometimes not all doors lock (same with manually locking door, not all doors lock)

The latest thing is, when I put the rear window heat switch on, the hazards will come on but at this stage I hear a clicking as well to the hazards.

One that hasnt happened recently was a few weeks back, driving home at night, my hazards kept coming on without being put on randomly.

I have checked what fuses I think are linked to electrics and have no problems, that said, few christmas's back my wipers stopped and it turned out a fues with a symbol I didnt think related to wipers was the problem, so would be grateful if that could be mentioned :grin:

Any help would be amazing and getting alittle worried that this is going to be a huge bill if I put it into a garage :(

Share this post


Link to post
Share on other sites

Sounds like the convenience ECU is fried, i'd also check the wiring between the doors and the cars body, inside the rubber boot, as they can wear over time and short out on each other.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0