Sign in to follow this  
Followers 0
websterm

E39 Instrument Cluster

5 posts in this topic

Hi all,

the intrument cluster on my 1998 E39 has developed a problem whereby the trip counter, odometre, temperature, MPG, etc part of the display shows at best a hieroglyphics, at worse nothing other than a faint glow. As the car warms the display become more hieroglyphic.

My question is, if I get a new cluster from ebay (or similar) will it display the milage from the original vehicle or the 117K that my Beemer has covered? I've heard that there are sensors, etc around the vehicle to stop clocking, but don't if this is true.

Thanks in advance

Share this post


Link to post
Share on other sites

We had the same problem on our gen 1 X5 about 6 years ago. At the time it was a well known fault on the E39 and the same clusters were used on the X5.

It's to do with the ribbon cables needing replacement. We rang BMW customer service and they agreed to change it out for a new recoded cluster for half an hour's labour charge. This was 6 years ago mind!

IIRC there's a few companies that will repair it for you while you wait if you get nowhere with BMW directly.

Share this post


Link to post
Share on other sites

got onto ebay & bought a replacement for £30 plus delivery - all is now good

Share this post


Link to post
Share on other sites
got onto ebay & bought a replacement for £30 plus delivery - all is now good

Good to hear that. Thanks for letting us know +++

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0