Andy_Bangle

Green M2

19 posts in this topic

I fecking love green cars. Think that's epic!

Share this post


Link to post
Share on other sites

Am I the only one who thinks the proportions are all wrong. The front and side of the car doesn't look like it goes together.

Share this post


Link to post
Share on other sites

Pictures do make it look a little odd, I suspect it's the camera lense as every 2'er I've seen in the metal looks great.

Not sure I'd spend my own money on that colour but it does look very good.

Share this post


Link to post
Share on other sites

Am I the only one who thinks the proportions are all wrong. The front and side of the car doesn't look like it goes together.

 

Will it is a hybrid - M3/M4 front and rear axles/brakes crammed into a bastardized 2er body shell  :cool:

 

BTW it's a green wrap, it's not available in that colour from the factory.

Edited by Andy_Bangle

Share this post


Link to post
Share on other sites

That looks sh!t the colour of a savoy cabbage leaf!

Share this post


Link to post
Share on other sites

That looks magnificent  +++  +++

 

Agreed. Sporty and aggressive.

Share this post


Link to post
Share on other sites

Love the colour but looks like it's on stilts!

Share this post


Link to post
Share on other sites

Love the colour but looks like it's on stilts!

It's got the shipping blocks in (the suspension). They're removed at PDI.

Back in the early days of the E46 M3 several cars were delivered to customers with the blocks in place as someone at Thorne, the BMW GB distribution center, forgot to remove them. Same also happened on some Z3's too.

Edited by Andy_Bangle
1 person likes this

Share this post


Link to post
Share on other sites

How about the Z4s? :)

5 people like this

Share this post


Link to post
Share on other sites

It's got the shipping blocks in (the suspension). They're removed at PDI.

Back in the early days of the E46 M3 several cars were delivered to customers with the blocks in place as someone at Thorne, the BMW GB distribution center, forgot to remove them. Same also happened on some Z3's too.

And one Z4 a few years ago....? :o

2 people like this

Share this post


Link to post
Share on other sites

And one Z4 a few years ago....? :o

 

I get you, fecker. :roflmao:

1 person likes this

Share this post


Link to post
Share on other sites

Quality green, but needs to be shiny!!  Not of this matt crap

1 person likes this

Share this post


Link to post
Share on other sites

Frozen green - blurrrrghhhhh, sorry not for me! +++

Share this post


Link to post
Share on other sites

+++  +++  +++  +++  +++

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now