Sign in to follow this  
Followers 0
geeonegee

Mk3 2l gti 8v 97 Anniversary ecu query

3 posts in this topic

Evening all

just bought a Blitzchip ecu chip from ebay,(is it any good ???) supposedly for the 8v 2l gti, followed the instructions with my good bud dazr32 and when we got inside the ecu housing to the pcb , with the aluminium cover which according to the instructions should have just unclipped from the pcb allowing access to the origianl ecu.

Part of the cover (the bottom portion) unclipped easily, unfortunately the top part of the cover was soldered on and we didnt want to risk buggering it up basically......anyone had a similar problem and could maybe shed some light on this....

Cheers beerchug.gifsmashfreakB.gif

Share this post


Link to post
Share on other sites

Not for that specifically, but my Lupo GTi actually had the ECU housing filled with gunk so opening the housing meant ECU was totally FUBAR - apparently this was done to prevent people changing emmissions by tuning - now it is possible that this has happened for a while and yours was done for the same reason in the factory?

Share this post


Link to post
Share on other sites

Definetely no gunk in the ecu housing....clean as a whistle in fact....just that the chip cover was uniformly spot soldered (10 spots 3-3-2-2)....does anyone know if it would damage the pcb if the solder was broken ??? bowdown.gifcoffee.gif

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0