Sign in to follow this  
Followers 0
durtydurty

Any GTV owners out there.....?

3 posts in this topic

Any of you out there, a few questions regarding running temperature and common faults.

Get in touch or PM if you'd like

Thanks in advance. 169144-ok.gif

Share this post


Link to post
Share on other sites

Hi there, There is a buying guide here for all the common faults that can be found with the GTV -

http://www.alfaowner.com/Forum/showthread.php?t=23905

Running temp should be about 90-ish in town, 70-85 on a run. Alfa radiators and thermostats are prone to wearing out pretty quickly. If it is taking ages to warm up when you keep moving (even in town) then it is quite likely that the thermostat is stuck in the open position.

Share this post


Link to post
Share on other sites

yeah, mine is a nightmare, I've had the oxygen sensor replaced but it's only helped a little bit, I doesn't idle well when it's cold at all, really annoying!

I know it sounds stupid, but how on earth do you change the wiper blades on the sods??? You can't lift up the arm even with the bonnet open. Mine is a 1999 model btw.

post-16316-137914388068_thumb.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0