Sign in to follow this  
Followers 0
paul_tdi

RETRO FITTING DIS AND CRUISE ON A4 B6

334 posts in this topic

Wrightio, reading your posts it seems your having trouble even fitting the N module version? It may be that your car is one of the few (early models) thats needs the 90cm long piece of wire for the steering column. I haven't got any instructions on me at the moment but Shark should have some in the post to him tomorrow smile.gif

Share this post


Link to post
Share on other sites

This could be possible!! I am at a complete loss now! It is a 2002 car so was hoping that all the loom etc would be in place! Look forward to hearing the news.

Interestingly I can see changes in code at the ECU when I play with the stalk?! I am very open to any suggestions and pointers as it is a constant learning process and it is really good to see that everyone here pulls together to solve these issues!

I am chuffed I am now able to enable DIS which I hope to be able to help others out with etc! I think if we can get it all sorted it will put both mine and Bens mind at rest! Oh and the wife!!!! lol.gif

thanks for the contact, as always very much appreciated!

Paul

Share this post


Link to post
Share on other sites

Paul, it sounds like yours may definately be without a wire frown.gif I can supply you the wire and fitting instructions to do it but its part of a £40.00 kit that includes a new Cruise stalk and bolts etc. YHPM

Share this post


Link to post
Share on other sites
smirk.gifMOre money shh she might find out!! Have replied to the PM u sent! THANKS for the help and support!!

Share this post


Link to post
Share on other sites

Maybe a silly question, I would like the DIS but ain't too fussed about cruise, is retro fitting the DIS only any easier?

What parts do you need for just the DIS?

Share this post


Link to post
Share on other sites

It all depends on the module u have in the car! Ben (shark 90) helped me out loads! I can do it now but only the B6 model! The stalk was about 60 quid from the dealer and as my cruise does not work at present and DIS does it would suggest the DIS can be installed. The B7 programming needs a specific programming CAN bus cable.

Share this post


Link to post
Share on other sites

From this post, I'll need more than luck confused.gif

It's not fair why is my neighbour NOT an Audi technician! laugh.gif

Share this post


Link to post
Share on other sites

There are plenty of people here that will help u out!! Ben notworthy.gif(shark_90) did more than I would have expected from a dealer to help me out with my cruise etc.

Good luck you will get it sorted somehow!!!

Paul

Share this post


Link to post
Share on other sites

Cheers for the praise Paul!

Nelson - I'm not sure Paul's car might be one of these "odd" cars that do need an extra wire, mainly because it's not actually that early (52 plate) and because there was a fault code for the cruise stalk when I did the initial scan of his car last weekend. After speaking to Paul I don't think the code has come back, but I'm not sure. Is the information for this bit of wire in the instructions I shall be receiving? Obviously one I've got to be aware of smile.gif

Share this post


Link to post
Share on other sites

HI Ben,

Going to check for faults etc tomorrow as used the car a little today. Worth trying on the provision that if this aint it I can then go guns blazing openfire.gif to audi! Worth a try and Neil knows it is a 52 plate car so we shall see what happens! He is selling me a complete cruise stalk setup so will try that too!

Hope u have had a good weekend matey!

Paul

Share this post


Link to post
Share on other sites

Not sure if this helps but the guy that fitted cruise on my B6 said he had a real nightmare the month before and it turned out to be a faulty or non existent (cannot remember which) clutch pedal switch which would not let the cruise activate.

He now checks that first on any problem cars.

Share this post


Link to post
Share on other sites

Timps you might be on to a winner there, it never crossed my mind. I've just had to change that very part on my car. Good thinking 169144-ok.gif

Share this post


Link to post
Share on other sites

HI Timps! You have just made mine and Bens day! Problem sorted! It is the blue switch that sits above the clutch pedal. Now bypassed and hey presto cruise we have!! 169144-ok.gif

Thanks very much for the pointer and it is nice to have a reasonably cheap fix for a change! Now that cruise and DIS is retro fitted and running 100% what next...... ECLIPSe.gif

Share this post


Link to post
Share on other sites

Good shout Timps, like I said I can't believe I didn't think of that, even though I had to change the clutch switch on mine only yesterday smashfreakB.gif

Paul - BOSE next wink.gif

Share this post


Link to post
Share on other sites

HI Ben, Keep us posted as at to how u get on as after having BOSE would love it again!

Mind u might see if the BOSE speakers I have can be put in for now!

Ideally if u source the amp and speakers I suspeect it may be worth seeing if u can get the necassary looms with it too?! Chuffed to bits we now sorted the problems with the cruise and that I too am able to do the cruise and retro fit of DIS and cruise!

After reading a few threads etc might have to purchase the RS4 uprated rear roll bar!! Sounds well worth it!

In the mean time looking forward to the next retro ideas!!!

Share this post


Link to post
Share on other sites

Paul - do the bar, it's a MUST! Best £90 I've ever spent beerchug.gif

Ring Martyn at VAGParts for it 169144-ok.gif

Share this post


Link to post
Share on other sites

If you think Bose is good you should try the Bang & Olufsen in the new S8 EEK2.GIF

Share this post


Link to post
Share on other sites

Ben / Paul, What did you guys do in the end about the screenwash warning? I heard you mention about fitting the sensor, or have you just grounded the pin? 169144-ok.gif

Share this post


Link to post
Share on other sites

HI Mitchet,

We have both grounded the pin but will install the sensor soon as I have one! Have u grounded your pin ok? It is a little awkward etc but not the worst job!

As soon as I get a sensor and install I will let you know!

Paul

Share this post


Link to post
Share on other sites

Yep, mine's grounded for the moment. Can't be that difficult to fit the sensor but to be honest I don't know if I'll bother for now. It's just nice not to have the fecking car beeping every time it's turned on!

Share this post


Link to post
Share on other sites

I haven't grounded the pin yet purley down to the lack of free time I've had recently. frown.gif

Out of interest, what did you use as the ground connection?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0