Sign in to follow this  
Followers 0
paul_tdi

RETRO FITTING DIS AND CRUISE ON A4 B6

334 posts in this topic

HI Mitchet,

I used a pin from my original wiper stalk I had to butcher after the stealers sold me a saloon DIS stalk! Then as Ben said just ran a length of wire to any ground. For now I used a bolt on the centre console as I intend to fit the sensor soon!!

Paul

Share this post


Link to post
Share on other sites

Just fitted the washer sensor yesterday and it was not too tricky!

1. Remove passenger front wheel

2. Remove wheel arch liner completely

3. Hole for sensor is located at base of reservoir, should be plugged, remove plug and allow to drain.

3. Used Spade terminals to connect wire to sensor, (I used speaker type wire so both ends will be run into cabin)

4. Seal the connections using silicon to ensure no water ingress and rout cable though top of wheel arch.

5. There as a large grommet to the right of the suspension that already has a large cable going through with a small "nipple" above and below where the cable goes through. Snip the end off and feed the cable through.

6. Inside the car I removed the glovebox to gain access to the grommet which ou should hopefully see the cable sticking through. (left of the blower housing)

7. Pull all excess cable through before refitting the inner arch cover and replacing wheel. (Check for leaks first!)

8. Route twin cable to drivers side and run one end to earth and the other to pin one behind the speedo as described earlier in the posts!

9. Put all the car together again and hey presto no warning light ( So long as you have filled with water!!)

Hope this is of use to someone! Let us know if you have any problems. Takes about 1 hour in all and you will need a torx screwdriver for the screws that hold the arch lining in and an 8mm socket to remove the glovebox!

Paul

Share this post


Link to post
Share on other sites

So is the sensor for the washer just those 2 bits of metal poking into the washer reservoir? I have got the sensor, so will have a bash at this soon.... Where is the plug under the dash I have to connect it to?

Shark_90 - did you get those pins for the plugs?

Chaz

Share this post


Link to post
Share on other sites

HI Chaz,

Yes thats it mate! I thought that it would not work but it does!! The pin is located behind the speedo on the left as you face it. It locates in pin one of the blue connector!

I have a spare pin that like I used if you want it, worked for me. PM me with your number if you like to discuss!

Paul

Share this post


Link to post
Share on other sites

Hi All

Was wondering if someone on here could help me. I have just bought a 2003 Audi A4 sport 1.9 TDI and would really like cruise and dis putting it on it. I looked at some dealers and garages but all prices around £500 upwards which i thought was a bit steep. I think i could quite happly fit the parts but i would struggle with the reprogramming. was wondering-: A if anyone could tell me where i could source the parts from besides the dealer and B if theres anyone around wolverhampton - Birmingham that could give me a hand with the reprogramming or could i just take it to an audi dealer and ask them to do it?

cheers Joel

Share this post


Link to post
Share on other sites

HI Joel, there is no need to pay steep prices, I would be able to do it but in dorset! I am sure you will get some response. Do you have VAG.com etc? You will need to see what steering control module you have first. If you need any more help/advice send us your number via PM and I will gladly give u a call.

Paul

Share this post


Link to post
Share on other sites

[ QUOTE ]

Hi All

Was wondering if someone on here could help me. I have just bought a 2003 Audi A4 sport 1.9 TDI and would really like cruise and dis putting it on it. I looked at some dealers and garages but all prices around £500 upwards which i thought was a bit steep. I think i could quite happly fit the parts but i would struggle with the reprogramming. was wondering-: A if anyone could tell me where i could source the parts from besides the dealer and B if theres anyone around wolverhampton - Birmingham that could give me a hand with the reprogramming or could i just take it to an audi dealer and ask them to do it?

cheers Joel

[/ QUOTE ]

Joel, I spend a lot of time in Hinckley which isn't too far away so I could do the whole job/programming for you. You have a PM 169144-ok.gif

Share this post


Link to post
Share on other sites

I'll be looking in to doing this on my 03 2.5tdi quattro when I get it (assuming its not got it on already) hope it goes a bit smoother than yours did Wrightio but its a good learning process i suppose. Where's the best place to get parts etc from and is there anyone near manchester that can do this for me /help me with it?

Share this post


Link to post
Share on other sites

Hi, just registered!

I am looking at an 03 A4 cabriolet, but it is a little short on a few things I see as important! Namely Sat Nav, Cruise and a Multi-function Steering Wheel (I am a bit of a motorway regular!)

I have a few questions!

Fitting Cruise is possible, I assume it would be easier (and cheaper) to do it at the same time as changing the steering wheel? Does anyone know what type of money I'd be looking at for this to be done? Not at a dealer, but at an indy garage - or by Shark_90 by the looks of this post.

Also I have been looking at a nav unit, http://tinyurl.com/jx86q would this be all I would need? Again what type of money would I be looking at to have it fitted?

Thanks in advance for any help!

Cheers

Andy

Share this post


Link to post
Share on other sites

As your in Liverpool, not far away from me, I can fit the nav system, bluetooth etc for your car, Shark is welcome to come over and do cruise, steering wheel etc at mine whilst I'm doing the Nav and whatever for you.

PM me for details.

Share this post


Link to post
Share on other sites

[ QUOTE ]

how much can you fit cruise control for on a new A4?

[/ QUOTE ]

You have a PM 169144-ok.gif

Share this post


Link to post
Share on other sites

Have just had cruise and DIS fitted on my car by Shark 90. A top job and a top bloke. Highly recomended.

Share this post


Link to post
Share on other sites

First, thanks to Shark90 for the excellent vag-com instructions which have just helped me enable cruise control!

Now I thought I'd add to this thread to add a few notes from my install today.

The steering wheel bolt is a T55 torx bolt which you will want to get a T55 socket to remove this. I used a breaker bar to remove with relative ease.

The two bolts holding the bottom steering plastic surround to the top are T8 torx bolts and you will need a small screwdriver with at least 60mm length on the shaft to remove them.

I bought a 15 piece precision screwdriver set from Maplin (code: N25CX) for a fiver (it has a 50mm shaft) and trimmed 10mm of the plastic off the end of the shaft to give me 60mm length with which to fit in the hole...

http://www.maplin.co.uk/Module.aspx?Modu...et&doy=19m1

Finally two bolts are underneath the steering column and these are T15 torx screws.

The only other thing to add is when you come to remove the storks, make sure you are removing the long (about 30mm) screws, not the small (about 10mm) screws, the small screws hold the unit together.

I managed to take my indicator stork to bits without realising and just about saved myself from disaster!

I followed the guide here with regards to taking things to bits...

http://www.harddrive.plus.com/Documents/A4/A4%20Cruise%20Control.pdf

Note that on the B6, you will need to follow the vag-com instructions above from Shark 90.

jump.gif

Share this post


Link to post
Share on other sites

Shark90 does it again!!!

Fitted cruise control in my a4 last week....works an absolute treat.

Nice one Sharky!

Share this post


Link to post
Share on other sites

Hi people, just fitted cruise control tonight with no bother at all. Trouble has arisen whilst trying to do the vagcom coding. When I enter to recode the steering module or engine module it wont save the changes after pressing "do it". I have a fully registered copy of vagcom but a cable bought through ebay, have never come across anyone anywhere saying this shouldnt allow me to make changes but could this be the problem? Any suggestions what could be the problem?

Thanks.

Share this post


Link to post
Share on other sites

[ QUOTE ]

Hi people, just fitted cruise control tonight with no bother at all. Trouble has arisen whilst trying to do the vagcom coding. When I enter to recode the steering module or engine module it wont save the changes after pressing "do it". I have a fully registered copy of vagcom but a cable bought through ebay, have never come across anyone anywhere saying this shouldnt allow me to make changes but could this be the problem? Any suggestions what could be the problem?

Thanks.

[/ QUOTE ]

The instructions are all there for you to read - use them and you'll be fine because they work flawlessly. I read them back everytime I do an install, and several people have managed to do the install themselves by reading the instructions.

Share this post


Link to post
Share on other sites

[ QUOTE ]

[ QUOTE ]

Hi people, just fitted cruise control tonight with no bother at all. Trouble has arisen whilst trying to do the vagcom coding. When I enter to recode the steering module or engine module it wont save the changes after pressing "do it". I have a fully registered copy of vagcom but a cable bought through ebay, have never come across anyone anywhere saying this shouldnt allow me to make changes but could this be the problem? Any suggestions what could be the problem?

Thanks.

[/ QUOTE ]

The instructions are all there for you to read - use them and you'll be fine because they work flawlessly. I read them back everytime I do an install, and several people have managed to do the install themselves by reading the instructions.

[/ QUOTE ]

Hi, been over the instructions from page 2 of this thread and I get the drift your meant to login to the steering controller 1st before you can save the recode, is this right? If so what possibly could the login code be? The ones you mention in the instructions are for the instrument controller not the steering controller, they dont work in any case as tried on the off chance! The link you gave to figure out a login dosent list details for the steering controller either! SO im lost basically! I can login to the engine ok, but cant activate the cruise control function in the steering controller!! Help appreciated although im sure your bored of being pestered about this by now as its an old thread!!

Share this post


Link to post
Share on other sites

Everyone will do all they can to help out mate. I know shark has been more than forthcoming to help out everyone, myself included.

I have replied to your pm.

Where abouts are you located?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0