Sign in to follow this  
Followers 0
paul_tdi

RETRO FITTING DIS AND CRUISE ON A4 B6

334 posts in this topic

No, you log in to the ABS controller when doing the recode. I take it your DIS is flashing (!) BRAKES at the moment in red?

Share this post


Link to post
Share on other sites

[ QUOTE ]

No, you log in to the ABS controller when doing the recode. I take it your DIS is flashing (!) BRAKES at the moment in red?

[/ QUOTE ]

Nope, getting no ABS warning at all. I already had DIS as a factory fit option so this is coded fine & havent had to change the steering controller for a new one, the original one in the car was the right one for cruise control too!

Share this post


Link to post
Share on other sites

Erm, are you sure about that? Do you have a multi function wheel? What's the part number of the controller and what year is your car?

Share this post


Link to post
Share on other sites

[ QUOTE ]

Erm, are you sure about that? Do you have a multi function wheel? What's the part number of the controller and what year is your car?

[/ QUOTE ]

Its a 2002 A4 3.0 V6 Quattro Sport manual, no multi function steering wheel. The dealer reckoned after I gave them my VIN I had steering module 8E0 953 549 N which I did indeed have as looked when I was fitting the cruise control stalk!

Share this post


Link to post
Share on other sites

What does VAG-COM report the controller number as if you connect to it?

Share this post


Link to post
Share on other sites

Vagcom says 8E0 953 549 F which the dealer said didnt exist, then asked for the VIN number and said it was the "N" version in the car.

Share this post


Link to post
Share on other sites

And there, my friend, is your problem.

Never trust a dealer. They know absolutely jack sh1t about your car, parts, or much else for that matter. According to the Audi parts system, suffix F does not exist. However it obviously does.

Simply, you don't have the right controller, which is why you can't code cruise in. So you'll have to buy a new one and so a full, proper retrofit as per the instructions.

Share this post


Link to post
Share on other sites

[ QUOTE ]

And there, my friend, is your problem.

Never trust a dealer. They know absolutely jack sh1t about your car, parts, or much else for that matter. According to the Audi parts system, suffix F does not exist. However it obviously does.

Simply, you don't have the right controller, which is why you can't code cruise in. So you'll have to buy a new one and so a full, proper retrofit as per the instructions.

[/ QUOTE ]

One word.............bugger!!! Was happy thinking I wouldnt need to replace the controller and put the saved cash towards something else, lucky I havent spent it yet! Will get on the phone to vagparts tomorrow & get myself a new "N" controller.

Thanks a billion for the help, should be straight forward enough form here on in I hope now!!

Share this post


Link to post
Share on other sites

Just to confirm that I had exaclty the same response when I checked with Audi. I double checked and the steering module was the same as the one you have. It would not work, ended up getting an N module.

Share this post


Link to post
Share on other sites

Happy Birthday Ben 169144-ok.gif

Hope you had/are having a good one........

Share this post


Link to post
Share on other sites

[ QUOTE ]

Just to confirm that I had exaclty the same response when I checked with Audi. I double checked and the steering module was the same as the one you have. It would not work, ended up getting an N module.

[/ QUOTE ]

Thanks again to both Paul & Ben, just ordered the "N" controller from vagparts along with a double din cage for the next project, a double din conversion to allow RNS-e install! Ordering now as it'll save on postage at a later date, plus can fit that and just slot in the RNS-e unit when I get round to ordering one!!

Share this post


Link to post
Share on other sites

Good news, I fitted the "N" version control module & it works perfectly now!! Thanks to all for the help & the excellent coding guide.

Share this post


Link to post
Share on other sites

i have a t designation control module which is of a b7 with a cruise stalk attatched to it ? anyone fitted one of these on a b6

Share this post


Link to post
Share on other sites

They should be backward compatible with a B6 but coding used modules in has been interesting in the past.

Share this post


Link to post
Share on other sites

Hi there,

Getting myself prepped to do the DIS/Cruise install on my B7 S-Line TDi.

I don't have a MFSW and have controller 8E0 953 549 S, I take it from what I have read I can enable DIS but not Cruise on this controller?

I think I'm going to bite the bullet and get a new controller as if I'm going to the hassle of taking the wheel off I might as well plug in an extra stalk and unit!!

My dealers (listens for the groans!!!) said that I would need 8E0 953 549 R, I realise this will work but was just canvassing for what other modules work with Cruise, I know N does.

I'm planning on taking lots of pictures and screen shots and making a comprehensive How-To guide for this so any extra nuggets like the types of controllers that work would be a bonus!

Will let you know how I get on.

Cheers

Paul

Share this post


Link to post
Share on other sites

Yeah, seen that one, very good.

That's loosely what I'm going to base mines on, but obviously adding the DIS stalk and some Vag-Com screen shots for the whole shebang!!

Just need to wait till I get paid now :)

Share this post


Link to post
Share on other sites

Hi there,

Well, the install is getting closer!!

Couple of questions, Ben you said that coding used SCSM's has been "intereting". Can you elaborate? I've got hold of a used 'N' type module to use.

Secondly, the pin for the instrument cluster, any ideas as to the type needed or even better the Audi part no for it?

I'm away down to Audi to order the lower cowling and washer level sender today so would like to get the cable too and know how arsy some parts places can be about the repair wires!!

Cheers for the help in advance

Paul :D

Share this post


Link to post
Share on other sites

I wouldn't use an N module on a B7 - never been done as far as I know (i.e. I've never done it :grin:)

Sometimes used SCSMs can be difficult to code and also show a fault code to say that the car's VIN is incorrect as the module codes itself to the car it's connected to. I did manage to clear the fault code once but as I never fit used modules to cars I can't remember how. The fault code will show up in a scan and if your car's under warranty it will almost certainly get found.

In a B7 there will already be a wire in pin 1, just solder another wire to it. It might even go to roughly the right part of the car for the washer bottle sensor.

Share this post


Link to post
Share on other sites

Hi guys - gatecrashing the conversation here, I am undertaking the same task as elPaulio , I have all the bits and bobs to get started (vagcom/washer stalk), just wondering where to find the wire/plug for the washer sensor - I know its in the instrument cluster - but where is that? Also am I going to need a new SCM? I have cruise

Cheers

Share this post


Link to post
Share on other sites
Hi guys - gatecrashing the conversation here, I am undertaking the same task as elPaulio , I have all the bits and bobs to get started (vagcom/washer stalk), just wondering where to find the wire/plug for the washer sensor - I know its in the instrument cluster - but where is that? Also am I going to need a new SCM? I have cruise

Cheers

I had a succesful retrofit of the multifunction wiper stalk to enable the trip computer functions; cruise was already in place. This link has the part numbers from my Canadian MY2008 B7 A4 Avant. No additional wiring needed, probably because i already had the headlight washer system installed.

http://www.audizine.com/forum/showpost.php?p=2464419&postcount=20

Share this post


Link to post
Share on other sites

Crikey, you're a bit behind over on Audizine aren't you? We've been doing this for at least 2 years over on Tyresmoke!

I think, although I have never done a "DIS only" retrofit to confirm, that nearly all modules are DIS capable, then cruise and DIS, then MFSW cruise and DIS. The part numbers keep changing and as I don't have an A4 any more I don't bother to keep up with them.

For reference, the washer bottle empty sensor should be connected to pin 1 of the blue connector in the back of the dashboard. If you don't want to retrofit the sensor, then you can ground this pin to disable the warning.

Share this post


Link to post
Share on other sites

Hi Ben,

Thanks for the heads up with the N module, i'll still give it a go cause if all else fails I can just put the old module back in and run the DIS but no cruise until I can get a new module, will let you know how that goes.

I'll need to have a good look and see where the wiring goes from Pin 1 in the B7 then and see if it is near the washer bottle! Guess it would be too much to hope for that it'd be wired in and a nice little plug will be hanging there where the sender goes waiting to be plugged in :D

I have heard of the now knowing VIN number problem with different modules, in particular the airbag, I believe you can log in in Vag-Com to the module and tell it to learn its VIN, hopefully that will work, will need to read up on it a bit more before I try the install me thinks!!

Will keep you all informed!!

Paul :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0