Jump to content

[Audi A3/S3] HELP S3 Pre Facelift - Facelift Centre Console & Throttle Sticking Problems


A3_Beast
 Share

Recommended Posts

Good Afternoon,

I have recently brought another 2001 Audi S3 and i am having a few problems with it. Any advice would be much appreciated.

Problem 1.

I decided to replace my facelift centre console & climate control

(Part Number: 8L0 820 043 H) -

complete pre facelift piano black center console & climate control

(Part Number: 8L0 820 043 M)

So i removed & disconnected the stereo then removed & disconnected the climate controls 4 plugs. When i installed the new unit i found that only 3 of the 4 plugs would fit. I connected the plugs that would fit and the unit didnt work.

The only time it would work was when the headlights were switched on which i thought was weird. It would stop working when the lights were turned off. When it was working it only worked for few seconds and then would stop and restart again.

To make things worse when i tried put back the old climate control it doesnt seem to work anymore.

Have i done something wrong or do i need a different harness ?

Is the climate control i got faulty or the wrong one to work properly?

Is it possible to replace complete centre console from pre facelift to facelift ?

If so will the hazard lights & ESP still work ?

Problem 2

I now regret this but I disconnected the battery to try and get the climate control to work again with no luck. Since doing this my cars revs seem to stick @ and above 3k RPMs

If i lift off the accelerator at around 3k to shift gears and the revs will hold slightly. Ie it will hover around the 3k mark for a second or so before going down. The higher in the rev range the worse the problem gets. This happended the first drive after connecting the battery back up.

The clutch has been replaced roughly 10k miles ago. I tested the car 30 MPH 5th gear to see if he clutch was slipping & it wasnt.

Is the problem something to do with my throttle body ?

Has disconnecting the battery caused this to happen ?

Any idea what needs to be done to fix ?

If anyone can help me with these problems i would be forever grateful.

Thanks in advance

post-33991-137914501375_thumb.jpg

post-33991-137914501379_thumb.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...