Jump to content

New Speedo KPH to MPH - VW Polo


telandy
 Share

Recommended Posts

My girlfried has just bought a VW Polo back to the Uk from the continent. We have changed the headlights, put on a foglight and have just changed to speedo for one with MPH on. No problems with swapping things over. I changed the speedo on Friday and we drove 3 miles and parked the car on the drive. Went to get in it this morning and the engine turns over and runs for about 2 seconds and dies. Turn the ket again, runs for two seconds and dies. It looks like there is no HT from the coil after you have turned the key.

My question, is there anything in the ECU that recognises a new speedo and has to be reset before the engine can run again.

Has anybody got any other ideas. Have tried putting the old speedo back, have checked the wiring etc and nothing looks out of place.

Ideas gratefully received.

Andy

Link to comment
Share on other sites

All Polo's up to the latest type (6N1 or 6N2 type)had a separate immobiliser control unit fitted behind the dashboard so you can change the instrument cluster without any problems. The latest type of Polo (9N1)has the immobiliser control unit built into the instrument cluster so this would require a key re-code. This can only be done by a VAG dealer as the required secret access code has to be obtained from VW-UK. The code is only valid for 24 hours so every time you change a component a new code will be required. To check which type of Polo you have check the chassis number, it will start with WVWZZZ9N or WVWZZZ6N.

If you put the original dash back in the car will start. Take the car to your local dealer and ask them to fit the new dash. They will then re-set the immobiliser in the new dash for your keys and engine control unit. This should take no longer than an hour.Good luck. SPericani2.gif

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...